ekeyd doesn't seem to recognize key

Steve Snyder swsnyder at snydernet.net
Tue Oct 4 17:48:15 BST 2011

You said that you're using the default config file, but the default config doesn't use /dev/ttyACM0.  It uses /dev/entropykey on the assumption that some other process has created that devnode (or symlink to a devnode).

I'm on CentOS v5.7 (i686) and just reference /dev/ttyACM0 directly in the config file.  udev on RHEL/CentOS 5.x is just too broken to automatically set up the devnodes correctly.  (Or at least it was on v5.6.  Maybe v5.7 is working better, but I haven't tried it.)

Note that the hard-coding of /dev/ttyACM0 won't work if you have multiple EntropyKeys installed.

-----Original Message-----
From: "Thomas, Chris" <CThomas at medplus.com>
Sent: Tuesday, October 4, 2011 12:25pm
To: entropykey-users at lists.simtec.co.uk
Subject: ekeyd doesn't seem to recognize key

EntropyKey-users mailing list
EntropyKey-users at lists.simtec.co.uk
I recently received my first entropy key to test in some of our systems.
At the moment I can't see to get ekeyd to recognize that the key is
there as ekeydctl won't list it.  System is RHEL 5.6 x86_64 running on
HP ProLiant BL465c G7.  Using the default config file.  It previously
worked fine in another machine, I even tried moving keyring from the
other machine.  Details follow...  Does anyone have any suggestions?




USB device is recognized:


[root at apg016 entropykey]# lsusb

Bus 007 Device 001: ID 0000:0000

Bus 007 Device 002: ID 03f0:7029 Hewlett-Packard

Bus 005 Device 001: ID 0000:0000

Bus 003 Device 001: ID 0000:0000

Bus 004 Device 001: ID 0000:0000

Bus 004 Device 002: ID 20df:0001 Simtec Electronics Entropy Key

Bus 002 Device 001: ID 0000:0000

Bus 001 Device 001: ID 0000:0000

Bus 006 Device 001: ID 0000:0000



ACM driver is loading:


[root at apg016 entropykey]# lsmod | grep acm

cdc_acm                48609  0



Serial device was created:


[root at apg016 entropykey]# ls -l /dev/ttyACM*

crw-rw---- 1 root uucp 166, 0 Oct  3 20:08 /dev/ttyACM0



Daemon running:


[root at apg016 entropykey]# service ekeyd status

ekeyd (pid  2273) is running...



Daemon does not see key:


[root at apg016 entropykey]# ekeydctl list




Software Installed:


[root at apg016 ~]# rpm -qa | egrep "ekey|lua"





Chris Thomas
MedPlus, A Quest Diagnostics Company | Senior Unix Administrator | 4690
Parkway Drive | Mason, OH 45040 USA | phone +1.513.204.2711 |
cthomas at medplus.com <mailto:CThomas at medplus.com>  | www.medplus.com


Confidentiality Notice: The information contained in this electronic transmission is confidential and may be legally privileged. It is intended only for the addressee(s) named above. If you are not an intended recipient, be aware that any disclosure, copying, distribution or use of the information contained in this transmission is prohibited and may be unlawful. If you have received this transmission in error, please notify us by telephone (513) 229-5500 or by email (postmaster at MedPlus.com). After replying, please erase it from your computer system.

More information about the EntropyKey-users mailing list