Entropy Key being zapped on boot.

Joshua Newton newton.joshua.x at gmail.com
Sat Oct 6 23:31:48 BST 2012

That's the best description I can give. I posted to the list some months
ago, saying that the EK doesn't work with Ubuntu 12.04. Actually, it does.
There's just one minor hang-up: I have to yank it out of the server and
plug it back in. At this point, I have no idea if it's down to the kernel
change (mainline stable on Gentoo to Ubuntu packages) or the complete
hardware change.

I've seen this behavior a time or two with USB flash drives, under Gentoo,
and at times kernel upgrades have fixed this problem and/or broken it
again. The EK has Just Worked in the meantime.

Interestingly... well, maddeningly ...the key works for a minute or so if
replugged on the server's USB2 ports.

If plugged into a USB3 port (controller: ASMedia), it still doesn't work on
boot--although it *appears* to be detected correctly as shown via
dmesg--but doesn't show up in 'ekeydctl list'... but it works, and
continues to work indefinitely(?) if I yank it and plug it back in.

On the next reboot, USB2 or USB3, the EK is detected but can't communicate
with ekeyd.

Has anyone experienced this sort of thing before? Do you have a fix or
workaround? Is there some sort of secret upgraded firmware I could push to
the EK? Is anyone living near Simtec HQ and willing to knock on the blasted
door and ask them to investigate the problem? (Obviously, my emails are
being ignored, same as everyone else's.) I can't have the EK failing on
boot. I'm not always around to interact with the server physically when it
needs to be restarted for patches.

At this point, I would throw out all my EKs and buy something much more
expensive, but I've been around Proper Professional Crypto Kit before, and
I already know what the support's like: dismal. ("Oh, you're trying to use
this on a 64-bit machine? Sorry, we only have a 32-bit driver. Do we what?
Have plans for a 64-bit driver? Well... would you like false hope or the
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.simtec.co.uk/pipermail/entropykey-users/attachments/20121006/dca690de/attachment.html>

More information about the EntropyKey-users mailing list